use strict;
my $str = 'BTS_33_198_D
PL_14_015
';
my $regex = qr/^([a-zA-Z]{2,4})(_)(\d{2})_(0*)(\d+)(_.+)?/mp;
my $subst = '\\1\\\\\\2\\3\\\\_%\\5%';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";