using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(blue|green)|(red|pink|yellow|gold|orange)|(ivory|brown|beige)";
string input = @"blue green red pink yellow gold orange ivory brown beige
green red pink orange ivory beige
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}