const regex = /(blue|green)|(red|pink|yellow|gold|orange)|(ivory|brown|beige)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(blue|green)|(red|pink|yellow|gold|orange)|(ivory|brown|beige)', 'gm')
const str = `blue green red pink yellow gold orange ivory brown beige
green red pink orange ivory beige
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}