// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(blue|green)|(red|pink|yellow|gold|orange)|(ivory|brown|beige)").unwrap();
let string = "blue green red pink yellow gold orange ivory brown beige
green red pink orange ivory beige
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}