re = /(blue|green)|(red|pink|yellow|gold|orange)|(ivory|brown|beige)/m
str = 'blue green red pink yellow gold orange ivory brown beige
green red pink orange ivory beige
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end