$re = '/(blue|green)|(red|pink|yellow|gold|orange)|(ivory|brown|beige)/m';
$str = 'blue green red pink yellow gold orange ivory brown beige
green red pink orange ivory beige
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);