package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(blue|green)|(red|pink|yellow|gold|orange)|(ivory|brown|beige)`)
var str = `blue green red pink yellow gold orange ivory brown beige
green red pink orange ivory beige
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}