#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\[([^\]]*)\].*"
Local $sString = "Zabbix: disk_avgerage[dae_1_0_disk_2]" & @CRLF & _
"Zabbix: disk_avgerage[dae_4_4_disk_1]" & @CRLF & _
"Zabbix: disk_avgerage[dae_5_1_disk_1]" & @CRLF & _
"Zabbix: disk_avgerage[dae_4_4_disk_9]" & @CRLF & _
"Zabbix: disk_avgerage[dae_5_0_disk_3]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")