import Foundation
let pattern = #".*\[([^\]]*)\].*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Zabbix: disk_avgerage[dae_1_0_disk_2]
Zabbix: disk_avgerage[dae_4_4_disk_1]
Zabbix: disk_avgerage[dae_5_1_disk_1]
Zabbix: disk_avgerage[dae_4_4_disk_9]
Zabbix: disk_avgerage[dae_5_0_disk_3]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)