const regex = new RegExp('.*\\[([^\\]]*)\\].*', 'gm')
const str = `Zabbix: disk_avgerage[dae_1_0_disk_2]
Zabbix: disk_avgerage[dae_4_4_disk_1]
Zabbix: disk_avgerage[dae_5_1_disk_1]
Zabbix: disk_avgerage[dae_4_4_disk_9]
Zabbix: disk_avgerage[dae_5_0_disk_3]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}