using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\[([^\]]*)\].*";
string input = @"Zabbix: disk_avgerage[dae_1_0_disk_2]
Zabbix: disk_avgerage[dae_4_4_disk_1]
Zabbix: disk_avgerage[dae_5_1_disk_1]
Zabbix: disk_avgerage[dae_4_4_disk_9]
Zabbix: disk_avgerage[dae_5_0_disk_3]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}