package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\[([^\]]*)\].*`)
var str = `Zabbix: disk_avgerage[dae_1_0_disk_2]
Zabbix: disk_avgerage[dae_4_4_disk_1]
Zabbix: disk_avgerage[dae_5_1_disk_1]
Zabbix: disk_avgerage[dae_4_4_disk_9]
Zabbix: disk_avgerage[dae_5_0_disk_3]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}