// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*\[([^\]]*)\].*").unwrap();
let string = "Zabbix: disk_avgerage[dae_1_0_disk_2]
Zabbix: disk_avgerage[dae_4_4_disk_1]
Zabbix: disk_avgerage[dae_5_1_disk_1]
Zabbix: disk_avgerage[dae_4_4_disk_9]
Zabbix: disk_avgerage[dae_5_0_disk_3]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}