using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{4}([-/.])\d{1,2}\1\d{1,2}";
string input = @"i'm using python regex to match dates in forms as: 1999-01-01 or 1999.1.1 or 1999-1-1. but not ones like 1999.1-1 or 1999-1.1.i.e. the signs between year month and day must be consistent. I use the following code to do it which is messy. is there a better way to do it?";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}