import re
regex = re.compile(r"\d{4}([-/.])\d{1,2}\1\d{1,2}")
test_str = "i'm using python regex to match dates in forms as: 1999-01-01 or 1999.1.1 or 1999-1-1. but not ones like 1999.1-1 or 1999-1.1.i.e. the signs between year month and day must be consistent. I use the following code to do it which is messy. is there a better way to do it?"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")