re = /\d{4}([-\/.])\d{1,2}\1\d{1,2}/
str = 'i\'m using python regex to match dates in forms as: 1999-01-01 or 1999.1.1 or 1999-1-1. but not ones like 1999.1-1 or 1999-1.1.i.e. the signs between year month and day must be consistent. I use the following code to do it which is messy. is there a better way to do it?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end