use strict;
my $str = 'i\'m using python regex to match dates in forms as: 1999-01-01 or 1999.1.1 or 1999-1-1. but not ones like 1999.1-1 or 1999-1.1.i.e. the signs between year month and day must be consistent. I use the following code to do it which is messy. is there a better way to do it?';
my $regex = qr/\d{4}([-/.])\d{1,2}\1\d{1,2}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}