# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.(?=:)//gm;t' <<< "martin123:123martin
scoprio8881:447juean"