$re = '/.(?=:)/m';
$str = 'martin123:123martin
scoprio8881:447juean';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;