use strict;
my $str = 'martin123:123martin
scoprio8881:447juean';
my $regex = qr/.(?=:)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";