re = /.(?=:)/m
str = 'martin123:123martin
scoprio8881:447juean'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result