const regex = new RegExp('.(?=:)', 'gm')
const str = `martin123:123martin
scoprio8881:447juean`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);