import re
regex = re.compile(r".(?=:)", flags=re.MULTILINE)
test_str = ("martin123:123martin\n"
"scoprio8881:447juean")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)