#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^_\n]+_){3}([0-9A-Za-z]+)(?:_[^_\n]+)*$"
Local $sString = "AAA_BBB_CCC_DDD_EEE" & @CRLF & _
"This_is_a_test" & @CRLF & _
"And_this_is_another_test" & @CRLF & _
"This is a test" & @CRLF & _
"And_this_is_another_test_again" & @CRLF & _
"This_is_a" & @CRLF & _
"This_is" & @CRLF & _
"This" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")