re = /^(?:[^_\n]+_){3}([0-9A-Za-z]+)(?:_[^_\n]+)*$/m
str = 'AAA_BBB_CCC_DDD_EEE
This_is_a_test
And_this_is_another_test
This is a test
And_this_is_another_test_again
This_is_a
This_is
This
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end