// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[^_\n]+_){3}([0-9A-Za-z]+)(?:_[^_\n]+)*$").unwrap();
let string = "AAA_BBB_CCC_DDD_EEE
This_is_a_test
And_this_is_another_test
This is a test
And_this_is_another_test_again
This_is_a
This_is
This
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}