import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^_\\n]+_){3}([0-9A-Za-z]+)(?:_[^_\\n]+)*$";
final String string = "AAA_BBB_CCC_DDD_EEE\n"
+ "This_is_a_test\n"
+ "And_this_is_another_test\n"
+ "This is a test\n"
+ "And_this_is_another_test_again\n"
+ "This_is_a\n"
+ "This_is\n"
+ "This\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}