using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^_\n]+_){3}([0-9A-Za-z]+)(?:_[^_\n]+)*$";
string input = @"AAA_BBB_CCC_DDD_EEE
This_is_a_test
And_this_is_another_test
This is a test
And_this_is_another_test_again
This_is_a
This_is
This
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}