#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-z0-9]+\-)+(\d{4})$"
Local $sString = "* Start at the End: How to Build Products That Create Change (2019)" & @CRLF & _
"* start-at-the-end-2019" & @CRLF & _
"* 5d597abf6cee070007c13c4b" & @CRLF & _
"* 978-0525534426" & @CRLF & _
"* 0525534423"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")