import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z0-9]+\\-)+(\\d{4})$";
final String string = "* Start at the End: How to Build Products That Create Change (2019)\n"
+ "* start-at-the-end-2019\n"
+ "* 5d597abf6cee070007c13c4b\n"
+ "* 978-0525534426\n"
+ "* 0525534423";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}