$re = '/([a-z0-9]+\-)+(\d{4})$/m';
$str = '* Start at the End: How to Build Products That Create Change (2019)
* start-at-the-end-2019
* 5d597abf6cee070007c13c4b
* 978-0525534426
* 0525534423';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);