const regex = /([a-z0-9]+\-)+(\d{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z0-9]+\\-)+(\\d{4})$', 'gm')
const str = `* Start at the End: How to Build Products That Create Change (2019)
* start-at-the-end-2019
* 5d597abf6cee070007c13c4b
* 978-0525534426
* 0525534423`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}