use strict;
my $str = '* Start at the End: How to Build Products That Create Change (2019)
* start-at-the-end-2019
* 5d597abf6cee070007c13c4b
* 978-0525534426
* 0525534423';
my $regex = qr/([a-z0-9]+\-)+(\d{4})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}