// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-z0-9]+\-)+(\d{4})$").unwrap();
let string = "* Start at the End: How to Build Products That Create Change (2019)
* start-at-the-end-2019
* 5d597abf6cee070007c13c4b
* 978-0525534426
* 0525534423";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}