$re = '/^\[[^\]]+\][^\n]+(?:\n[^\[\n][^\n]+)*/m';
$str = '[08-Jul-2018 08:12:04 UTC] PHP Fatal error: on line 44
[08-Jul-2018 08:22:22 UTC] PHP Fatal error: in ...:37
Stack trace:
#0 C:\\xampp\\htdocs\\wordpress\\wp-content\\themes\\news_theme\\index.php(37):
PDOStatement->execute()
#1 C:\\xampp\\htdocs\\wordpress\\wp-includes\\template-loader.php(74):
include(\'C:\\\\xampp\\\\htdocs...\')
thrown in ... on line 37
[08-Jul-2018 08:12:45 UTC] PHP Fatal error: on line 155
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);