import re
regex = re.compile(r"^\[[^\]]+\][^\n]+(?:\n[^\[\n][^\n]+)*", flags=re.MULTILINE)
test_str = ("[08-Jul-2018 08:12:04 UTC] PHP Fatal error: on line 44\n\n"
"[08-Jul-2018 08:22:22 UTC] PHP Fatal error: in ...:37\n"
"Stack trace:\n"
"#0 C:\\xampp\\htdocs\\wordpress\\wp-content\\themes\\news_theme\\index.php(37): \n"
"PDOStatement->execute()\n"
"#1 C:\\xampp\\htdocs\\wordpress\\wp-includes\\template-loader.php(74): \n"
"include('C:\\\\xampp\\\\htdocs...')\n"
"thrown in ... on line 37\n\n"
"[08-Jul-2018 08:12:45 UTC] PHP Fatal error: on line 155\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")