#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d[\d.]*)x(\d[\d.]*)(?:x(\d[\d.]*))?"
Local $sString = "zzz 3062 0.2 aaa 15.8x20.2x12.2875 mm" & @CRLF & _
"zzz 3062 0.2 aaa 15.8x20.2 mm"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")