re = /(\d[\d.]*)x(\d[\d.]*)(?:x(\d[\d.]*))?/
str = 'zzz 3062 0.2 aaa 15.8x20.2x12.2875 mm
zzz 3062 0.2 aaa 15.8x20.2 mm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end