using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d[\d.]*)x(\d[\d.]*)(?:x(\d[\d.]*))?";
string input = @"zzz 3062 0.2 aaa 15.8x20.2x12.2875 mm
zzz 3062 0.2 aaa 15.8x20.2 mm";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}