$re = '/(\d[\d.]*)x(\d[\d.]*)(?:x(\d[\d.]*))?/';
$str = 'zzz 3062 0.2 aaa 15.8x20.2x12.2875 mm
zzz 3062 0.2 aaa 15.8x20.2 mm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);