import Foundation
let pattern = #"(\d[\d.]*)x(\d[\d.]*)(?:x(\d[\d.]*))?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
zzz 3062 0.2 aaa 15.8x20.2x12.2875 mm
zzz 3062 0.2 aaa 15.8x20.2 mm
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)