package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d[\d.]*)x(\d[\d.]*)(?:x(\d[\d.]*))?`)
var str = `zzz 3062 0.2 aaa 15.8x20.2x12.2875 mm
zzz 3062 0.2 aaa 15.8x20.2 mm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}