#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\s|^)([a-z0-9-.])+@+([a-z0-9-]*)\.([a-z]*)\s"
Local $sString = "this regex is intended to find emails with tld level 1 from a text test@domain12.com this a text after email to check detection" & @CRLF & _
"test@domain12.com this is another text to test regex for that i had to write down some email something-new@gmail.com to another.email@gmail.com test123@domain-12.com test@domain.co" & @CRLF & _
"sample@organization.org test.abc@domain.ac.nz test@abc.co" & @CRLF & _
"example@testdomain.net" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")