const regex = /(?<=\s|^)([a-z0-9-.])+@+([a-z0-9-]*)\.([a-z]*)\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s|^)([a-z0-9-.])+@+([a-z0-9-]*)\\.([a-z]*)\\s', 'gm')
const str = `this regex is intended to find emails with tld level 1 from a text test@domain12.com this a text after email to check detection
test@domain12.com this is another text to test regex for that i had to write down some email something-new@gmail.com to another.email@gmail.com test123@domain-12.com test@domain.co
sample@organization.org test.abc@domain.ac.nz test@abc.co
example@testdomain.net
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}