use strict;
my $str = 'this regex is intended to find emails with tld level 1 from a text test@domain12.com this a text after email to check detection
test@domain12.com this is another text to test regex for that i had to write down some email something-new@gmail.com to another.email@gmail.com test123@domain-12.com test@domain.co
sample@organization.org test.abc@domain.ac.nz test@abc.co
example@testdomain.net
';
my $regex = qr/(?<=\s|^)([a-z0-9-.])+@+([a-z0-9-]*)\.([a-z]*)\s/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}