import Foundation
let pattern = #"(?<=\s|^)([a-z0-9-.])+@+([a-z0-9-]*)\.([a-z]*)\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
this regex is intended to find emails with tld level 1 from a text test@domain12.com this a text after email to check detection
test@domain12.com this is another text to test regex for that i had to write down some email something-new@gmail.com to another.email@gmail.com test123@domain-12.com test@domain.co
sample@organization.org test.abc@domain.ac.nz test@abc.co
example@testdomain.net
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)