# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\s|^)([a-z0-9-.])+@+([a-z0-9-]*)\.([a-z]*)\s"
test_str = ("this regex is intended to find emails with tld level 1 from a text test@domain12.com this a text after email to check detection\n"
"test@domain12.com this is another text to test regex for that i had to write down some email something-new@gmail.com to another.email@gmail.com test123@domain-12.com test@domain.co\n"
"sample@organization.org test.abc@domain.ac.nz test@abc.co\n"
"example@testdomain.net\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.