$re = '/(?<=\s|^)([a-z0-9-.])+@+([a-z0-9-]*)\.([a-z]*)\s/m';
$str = 'this regex is intended to find emails with tld level 1 from a text test@domain12.com this a text after email to check detection
test@domain12.com this is another text to test regex for that i had to write down some email something-new@gmail.com to another.email@gmail.com test123@domain-12.com test@domain.co
sample@organization.org test.abc@domain.ac.nz test@abc.co
example@testdomain.net
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);