#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<([A-z0-9-_]+)(([^>"]+"[^"]*")*\s*)/>"
Local $sString = " <div class="bbn-flex-fill">" & @CRLF & _
" <div v-if="arrowsPosition.startsWith('top')"" & @CRLF & _
" class="bbn-flex bbn-bottom-sspace"" & @CRLF & _
" :style="arrowsStyle">" & @CRLF & _
" <i v-show="showArrowLeft"" & @CRLF & _
" :class="[leftArrowClass, 'bbn-p', 'bbn-lg']"" & @CRLF & _
" @click="prev"" & @CRLF & _
" :style="{visibility: (currentIndex === 0 && !loop)? 'hidden' : 'visible'}"/>" & @CRLF & _
" <i v-show="showArrowRight"" & @CRLF & _
" @click="next"" & @CRLF & _
" :class="[" & @CRLF & _
" rightArrowClass," & @CRLF & _
" 'bbn-p'," & @CRLF & _
" 'bbn-lg'" & @CRLF & _
" ]"" & @CRLF & _
" :style="{visibility: (currentIndex >= items.length - 1) && !loop ? 'hidden' : 'visible'}"/>" & @CRLF & _
" </div>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")