use strict;
my $str = ' <div class="bbn-flex-fill">
<div v-if="arrowsPosition.startsWith(\'top\')"
class="bbn-flex bbn-bottom-sspace"
:style="arrowsStyle">
<i v-show="showArrowLeft"
:class="[leftArrowClass, \'bbn-p\', \'bbn-lg\']"
@click="prev"
:style="{visibility: (currentIndex === 0 && !loop)? \'hidden\' : \'visible\'}"/>
<i v-show="showArrowRight"
@click="next"
:class="[
rightArrowClass,
\'bbn-p\',
\'bbn-lg\'
]"
:style="{visibility: (currentIndex >= items.length - 1) && !loop ? \'hidden\' : \'visible\'}"/>
</div>
</div>';
my $regex = qr~<([A-z0-9-_]+)(([^>"]+"[^"]*")*\s*)/>~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}